The G7 EditorΒΆ

Although you may use any ASCII text editor to edit the scripts, configuration files, and other text input that you may need to operate the software, G7 features its own text editor that works much like Windows WordPad. (WordPad itself is available under the File item of the main menu.)

To start the G7 editor, choose File | Editor. The editor window will appear in the upper right corner of the screen. To edit an existing file, choose File | Open ..., and then pick a file from the dialog box. When you have finished working on the file, select Save or Save As from the File menu. There is no need to close the editor before using the file.

By clicking Editor on the G7 main menu, you can open a new editor window while leaving the existing one open. The new one, however, will be in the same upper right corner; to see them both, you must drag the top one to a new position or select the desired window from the Window menu in the main G7 window. You may choose a default position for the editor window, so that G7 will open each new editor window in the desired place. To establish this default position, open an editor window and then click File | Save Window Position in the editor menu.

Either clicking the Find menu item on the Editor main menu or tapping ‘Ctrl-F’ will bring up a standard Find dialog to search for a string. To search for the same word again, simply tap the ‘F3’ key. A Find and Replace tool can be opened by clicking the Replace menu item or by tapping ‘Ctrl-R’.

Clicking Save on the Editor’s menu or tapping ‘Ctrl-S’ saves the current contents of the editor. “Save As ...” is on the File menu, as are commands for changing the font and background color. Although you can choose special fonts and colors, none of that formatting is saved when you click the Save button, only the ASCII text. This behavior is because the formatting information would stop the files from working correctly as input to G7. However, the selected font information is saved to the G7 configuration file (GReg.ini), and these settings will be restored each time an editor window is opened; text in the editor will be displayed in the chosen font.

Clicking Run on the Editor’s menu or tapping ‘F9’ saves the current contents and executes the file as a G7 command file.

Shortcuts
Many shortcuts can be executed by pressing the “Alt” key plus a character that is underlined in the corresponding G7 editor menu command. For example, “Alt+R” will execute the file in the G7 editor. Other useful shortcuts include:
Ctrl+f:Find
Ctrl+r:Replace
Ctrl+o:Open a new file in the same editor window, or open the selected file name in a new window.
Ctrl+s:Save
F1:Launch G7 Help files
F3:Find again
F9:Execute the file that is open in the editor
F10:Execute the text that has been selected in the editor.
F11:Execute the text from beginning of file to the cursor.

G7 Editor Window Properties

Set properties of the G7 editor windows, where font names and colors may be taken from the lists in the xl help pages and where other options may be specified as <0|1>, <yes|no>, <false|true>, or <off|on>.

edfontname <name>:
 Set the typeface in the editor window.
edfontsize <size>:
 Set the size of the type in the editor window.
edfontcolor <color>:
 Set the font color in the editor window.
edcolor <color>:
 Set the background color of the editor window.
edfontbold <0|1>:
 Specify the bold setting in the editor window.
edfontitalic <0|1>:
 Specify the italic setting in the editor window.
edfontunderline <0|1>:
 Specify the underline setting in the editor window.
edfontstrikeout <0|1>:
 Specify the strikeout setting in the editor window.

Mouse Menu

Right-click on the Editor window to bring up a menu. Menu options allow the standard Cut, Copy, and Paste operations. In addition, a filename may be selected from the dialog and the file name will be inserted into the text, or another file may be opened in the current window. Finally, if a series name or algebraic expression has been selected, then the “Type Series” option will print the data to the output window and the “Graph Series” option will display the data in a graph.

Previous topic

Looking at a Series in a Data Bank

Next topic

The G7 Command Reference

This Page